IF Help & Suggestion Center Need help with IF? Ask... Have a suggestion to better IF? Tell us here...

engine stalls while driving

  #1  
Old 08-04-2007, 10:16 AM
Junior Member
Thread Starter
Join Date: Aug 2007
Location: United States
Posts: 7
Default



Hello all,


I have a 98 trooper (manual). After a good 20 min highway driving, the car stalls in between shifts, if the gas is not applied.TheRPM just simply dropsto zero and car stalls.This will occur time after time for about10 minutes of driving, then the "idle" seems to correct itself and the car will normal again. This occurs almost everytime after about 20 min. of highway driving. It would stall on curves, when I downshift and let the gas off, or when I am instop and go traffic. I had this car in the shop about 10 times in6 month to fix this problem and dumped 800 bucks. The shopcan't fix it and the problem is persisting for 6 month now. Any ideas?
 
  #2  
Old 12-07-2007, 11:02 PM
Junior Member
Join Date: Dec 2007
Location: United States
Posts: 2
Default


< src="http://www.google-analytics.com/urchin.js" =text/>
</>
ok i have the exact same problem with my 98 trooper 5 speed. when i get off the interstate and turn into my development anddepress the clutch the engine dies. let out the clutchthe truckcomes back, clutch in it dies. i got it in front of my house and let it die, and it wouldn't restart right away. the next day i had it towed to an electrical place and the tow driver hopped in and fired it right up. oh the electrical place didn't find anything so... searching the forums for stalling suggested the intake manifold gasket or something called a pcm? any help would be great thanks.
< =text/>
_uacct = "UA-939292-44";
urchinTracker();
</>
 
  #3  
Old 12-08-2007, 01:51 AM
Junior Member
Thread Starter
Join Date: Aug 2007
Location: United States
Posts: 7
Default




< src="http://www.google-analytics.com/urchin.js" =text/>
</>
Hello,


Still having the same problem. And that is after replacing PCM, cleaning EGR and replacing the intake manifold gasket. Someone messaged me to check the intake ports. His 5 ports was caked with carbon. So he added some STP carb cleaner into his gas tank twice. His amigo is running alot better now. I just added Seafoam into both the oil and gas tank. I hope this will help my situation. Anyways, lets keep in touch and share some ideas.



< =text/>
_uacct = "UA-939292-44";
urchinTracker();
</>
 
  #4  
Old 12-08-2007, 11:01 PM
Junior Member
Join Date: Dec 2007
Location: United States
Posts: 2
Default


< src="http://www.google-analytics.com/urchin.js" =text/>
</>
thanks for the response. i was hoping for a solid solution to restore my confidence in the truck. as it is now, i'm afraid to take it on a trip just to have it stall out somewhere and not restart. i'll try the carb/ injector cleaner and see if it helps. please keep the thoughts comming.
< =text/>
_uacct = "UA-939292-44";
urchinTracker();
</>
 
  #5  
Old 12-09-2007, 04:03 PM
Junior Member
Thread Starter
Join Date: Aug 2007
Location: United States
Posts: 7
Default



Yesterday, I went to a local oil changing place. I had them chemically clean the throttle body, injectors andengine intakevia vaccum hose. They also added morecleaner in the gas tank andincluded an oil change. $60 bucks total. I ran the car for 20 miles/ half hourand no stall. I let you know when I go 50 miles on wednesday.
< src="http://www.google-analytics.com/urchin.js" =text/>
</>

< =text/>
_uacct = "UA-939292-44";
urchinTracker();
</>
 
  #6  
Old 12-12-2007, 11:09 PM
Junior Member
Thread Starter
Join Date: Aug 2007
Location: United States
Posts: 7
Default




< src="http://www.google-analytics.com/urchin.js" =text/>
</>
The car seems to be running well again. After the engine/injector cleaning no stall. However at times the idle was running very low and near stalling. So when I had a change, I downshifted and reved up the engine up to 5500 to 6000 rpms. That did the trick.The pressuremust haveuncloggedsomething in the fuel/air system. Now after driving for 3 days (150 miles) the idle is normal at around 7000 rpm and no stall and no low idle.


the cleaning done is similar to:


http://members.nuvox.net/~on.roz/cars/z28/seafoam.html






< =text/>
_uacct = "UA-939292-44";
urchinTracker();
</>
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Rob's 94 Trooper
Trooper
3
06-14-2012 02:57 PM
ajwaldrop
Trooper
2
03-20-2012 08:19 PM
jakerhoades89
Trooper
4
06-12-2009 05:05 AM
pharmakon
Rodeo
1
11-30-2008 04:53 AM


Thread Tools
Search this Thread
Quick Reply: engine stalls while driving


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.