General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

99 amigo check engine light

  #1  
Old 11-10-2006, 07:31 PM
Member
Thread Starter
Join Date: Nov 2006
Location: United States
Posts: 53
Default

Hi I posted in the amigo section .I have a 99 amigo i changed out a bad motor.the check engine light comes on for a couple of days and goes off for a couple of days.I had it to 2 mechanics and it came up engine misfire and cam sensor.I changed out 3 different cam sensors and the light still comes on,i changed egr,both 02 sensors ,map sensor,plugs wires,coil pac,injectors and even tried a diff computer it does exactly the same thing.I don't know what I could possbly be missing.this thing runs like a top and doesnt miss at all.plugs arent fouled.anybody have any ideas ? Am i missing something simple ? This thing is driving me crazy. I bought this truck with a bad motor and called the guy I bought it from and he said the light wasn't on when he had it.I was thinking a problem with bad wire somewhere but why would it not come up right away,I can drive for a couple of days before the light comes on .The light will go off and I even had it inspected and it passed when the light went off.PLEASE HELP
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ish
IF Help & Suggestion Center
2
06-13-2013 06:42 AM
xcountrycowboy
General Tech
0
01-03-2013 12:08 AM
sammie white
Rodeo
1
09-29-2011 10:50 AM
collyswamper
IF Help & Suggestion Center
0
03-22-2008 11:27 AM
nwtraveler469
Amigo
2
02-22-2008 08:10 AM


Thread Tools
Search this Thread
Quick Reply: 99 amigo check engine light


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.