'94 pickup 2.3 no spark, no ground pulsing - Isuzu Forums - Isuzu Enthusiasts Forum


General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-31-2018, 11:20 AM
Junior Member
Thread Starter
 
Join Date: Mar 2018
Posts: 4
Default '94 pickup 2.3 no spark, no ground pulsing

Hey, I have a 1994 pickup with a carbureted 2.3. I have no spark. I have tested and replaced coil, ignition control module, plugs, wires,cap and rotor are in good condition, the clutch switch is jumpered, and this year and engine don't have a crank angle sensor. I have 12v at coil wire connection but no ground pulsing. Still no spark. Anyone have an idea where to go next. Thanks for your input.
Reply With Quote
  #2  
Old 04-01-2018, 11:27 AM
Member
 
Join Date: May 2010
Posts: 77
Default

Quote:
Originally Posted by radioflyer View Post
Hey, I have a 1994 pickup with a carbureted 2.3. I have no spark. I have tested and replaced coil, ignition control module, plugs, wires,cap and rotor are in good condition, the clutch switch is jumpered, and this year and engine don't have a crank angle sensor. I have 12v at coil wire connection but no ground pulsing. Still no spark. Anyone have an idea where to go next. Thanks for your input.
Have you checked to see if any OBD-I codes have been set?
Reply With Quote
  #3  
Old 04-02-2018, 07:40 AM
Junior Member
Thread Starter
 
Join Date: Mar 2018
Posts: 4
Default

I have not yet checked codes. I have pulled the coil and ignition control module out and will have them tested again today by a different place, then will see about pulling codes with known good coil and icm. I had an old and new icm tested couple of days ago and they said new was good but old was bad. This makes sense but the continued lack of spark from the coil doesn't. The parts store didn't seem overly confident with their equipment either so I wanted to take coil and icm out of equation by having them tested by a different place. I understand that the computer on this 1994 2.3 model only controls the carb? Thought this would be an easy fix but will now backtrack and pull codes. I've checked all fuses as well. I'm sure it has to do with the coil or icm as I'm getting power to the coil but no spark out. Thank you for taking the time to reply.
Reply With Quote
  #4  
Old 05-14-2018, 05:40 PM
Junior Member
 
Join Date: May 2018
Posts: 2
Default

What was the out come of the issue im having the same problem ans replaced everything already stil no spark
Reply With Quote
  #5  
Old 05-15-2018, 09:38 AM
Junior Member
Thread Starter
 
Join Date: Mar 2018
Posts: 4
Default

Shawn, I recently cleaned, adjusted all my ignition stuff, replaced the pickup coil as well and still no spark. I've added grounds etc., had icms replaced and tested. I haven't yet checked obd codes as I know I don't have spark and the codes that will probably come up, (42, 43), won't tell me anything I don't already know. Today I'm going to check the timing belt just to make sure, double check the new coil for ground pulsing and battery ground voltage. If no success then I'll replace the distributor with a remanufactured. I've been trying not to shell out another 150 for the dist. but this is where I am. Good luck with yours.
Reply With Quote
  #6  
Old 05-15-2018, 12:12 PM
Junior Member
 
Join Date: May 2018
Posts: 2
Default

Thanks, yeah i have no ground pulse at coil. New coil, ecm, dist and control module. Still no pulse. I added afew more grounds to motor also
Reply With Quote
  #7  
Old 05-16-2018, 09:15 AM
Junior Member
Thread Starter
 
Join Date: Mar 2018
Posts: 4
Default

It's a bit of a long shot but I have my clutch switch jumpered so that that switch is out of the equation. With that switch jumpered, (male spade-wire-male spade), if my truck would start it could start without having the clutch depressed. Back when my truck was running my clutch was jumpered and the truck started or tried to start regardless of the clutch position. I still suspect the ignition control module since I'm not getting spark out of the coil, but I've replaced it with a new one, and had that new icm tested. Keep me posted if you have a breakthrough and I will do the same.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
89 pickup no spark andrewvw Pickup 1 07-29-2013 04:55 PM
93 4x4 Isuzu 2.6L pickup flooding spark plug Roads? General Tech 0 03-19-2010 10:52 AM
Ground Wire the_ocho Trooper 0 08-15-2008 10:53 AM
Electrical problem, bad ground? farm1810 Amigo 0 11-17-2006 01:15 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors

All times are GMT -5. The time now is 04:12 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.