Rodeo Talk about Isuzu Rodeo related topics here...

1998 rodeo, no power im stumped

  #1  
Old 08-27-2011, 08:36 PM
Junior Member
Thread Starter
Join Date: Aug 2011
Posts: 1
Default 1998 rodeo, no power im stumped

I just bought this truck and it is being very difficult, i see a bunch of threads and google topics with the same problem but i never see where anyone posts how to fix it. It starts and idles fine, normaly, but when i go to drive it has no power, cant go over 30, have to apply the gas very softly if i push to hard on the pedal it boggs down. I thought it was cloged cats so i cut them but it made no difference, the only codes its reading are oxygen sensors but no check engine light it on, it has a new fuel pump, and i can see where someone has removed the intake and put new seals, as well as a new mass airflow sensor and altenator. It is running on all 6 cylinders. I dont know what to do, i think it might have a bad ecm but i dont want to go just buying parts that dont fix it, thanks
 
  #2  
Old 08-30-2011, 12:40 PM
Junior Member
Join Date: Aug 2011
Location: Citrus Heights, CA
Posts: 4
Default

Have you removed your EGR valve? Clean it out so that the spring loaded pin moves freely. put it back on and see if it helps. I say clean it first because there not cheap.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
redleader
Trooper
3
10-16-2010 09:57 PM
lollypop
Rodeo
1
09-19-2008 06:42 AM
lollypop
Rodeo
0
09-11-2008 07:03 AM
Dedd2000
Rodeo
2
04-07-2008 07:44 PM
cowboys78
Rodeo
3
03-28-2007 09:05 PM


Thread Tools
Search this Thread
Quick Reply: 1998 rodeo, no power im stumped


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.