New Member Area New to IF? Stop in tell us about you...

2002 engine swap issue

  #1  
Old 09-29-2013, 12:45 PM
Junior Member
Thread Starter
Join Date: Sep 2013
Posts: 1
Default 2002 engine swap issue

I have a 2002 Rodeo LS 3.2 v6 and had to replace the engine. The salvage yard sold me a 2001 engine and said it was a direct swap. Once I assembled the engine/trans I noticed the 2001 did not have O2 connectors on the trans portion of the harness. I swapped over the harness from the original engine and everything plugged up the same but I do not have any spark at the plugs. I have 5 volts on the white wire at the crank position sensor. I checked the crank sensor at a local parts store and the 2001 is a different sensor than the 2002, but the crank itself is the same for the 2001 and 2002.
Another puzzling issue is the cam sensor. My book says the cam sensor is located under the intake manifold on the rear in the left head. My original wiring harness and the harness from the 2001 engine do not have any connectors on that section of the wiring harness.
Not sure where to go from here, pull the engine again or buy a new crank position sensor. I already sold the old engine so I can't get the original CKP sensor and don't want to spend $160 if the 2001 engine will not work in the 2002.
Any help would be greatly appreciated.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
AntonVN
Rodeo
0
10-07-2013 01:08 PM
Kwint
Rodeo
0
09-01-2012 08:21 AM
justpow
Rodeo
3
11-18-2011 09:59 AM
xpumpx
General Tech
0
08-14-2011 01:20 PM
86TWODOOR
Trooper
2
01-07-2006 12:53 PM


Thread Tools
Search this Thread
Quick Reply: 2002 engine swap issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.