New Member Area New to IF? Stop in tell us about you...

1999 3.5 4X4 TOD only 75K NO POWER

  #1  
Old 05-16-2018, 01:30 PM
Junior Member
Thread Starter
Join Date: Apr 2018
Location: California
Posts: 3
Default 1999 3.5 4X4 TOD only 75K NO POWER

Hello

Purchased new ‘02 Limited and regretted selling it. Found 99 w/ 75K one owner. Ran great, tapped danced like Shirley Temple but heard very common. Few weeks go by and on highway heard what I thought was backfire. No dummy lights, chalked it up to hearing things. I replaced plugs, pretty clean, little to no carbon. Changed oil. Next few days, popping and major loss of power. More I replaced for spark and air flow maintenance, the worse it got. Now any increase in rpm sounds like back pressure into air intake filter area. Doesn’t burn oil, doesn’t drip a drop. Newer timing belt and water pump. I’ve also replaced a new MAF. She’s ran great until now. I’ve seen plenty of these issues on Rodeos but no help provided. Any assistance appreciated.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
33Chevy
Private For Sale/Trade Classifieds
3
10-05-2016 06:39 PM
jakhammer43
VehiCROSS
0
12-11-2015 09:13 PM
g2turbo
Private For Sale/Trade Classifieds
2
11-11-2007 10:10 PM
g2turbo
Private For Sale/Trade Classifieds
0
09-13-2007 01:14 AM


Thread Tools
Search this Thread
Quick Reply: 1999 3.5 4X4 TOD only 75K NO POWER


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.