General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

roar?

  #1  
Old 02-24-2006, 12:45 AM
Junior Member
Thread Starter
Join Date: Feb 2006
Location: United States
Posts: 1
Default



I jus bought a 1994 4wdisuzu trooper $2,000. its in great condition,no leaks 117k miles, auto....Can anyone tell me why this suv roars really loud before it gets to about 40 mph? And also, the engine smells like gas really bad on the passenger side, i have no idea where it can be coming from!! Ive never owned one of these, i used to collect classic bmw's so this is a big change!Someone please help me thanks!





Oh and also, the front passenger window doesnt operate and either does the rear passenger window. but front driver side works and so does the rear driver side. !?





[img]uploads/trooper88/5294D_my_trooper.jpg[/img]





email- [email protected]-StuartEdited by: trooper88
 
  #2  
Old 03-16-2006, 02:57 PM
Super Moderator
Join Date: Mar 2005
Location: United States
Posts: 172
Default

roars? i dont understand...
 
  #3  
Old 03-21-2006, 09:21 PM
Junior Member
Join Date: Mar 2006
Location: United States
Posts: 6
Default

OK roars my 86 Isuzu trooper dose the same thing might be your tires if you have m/s all season's on it there meaty tires and can cause a roar i have had this experience. also check your fuel pump they have a hose that goes straight down and its to let you now that your fuel pump is going bad its a weep pipe. mine smelt like gas bad and i checked it and it was my fuel pump going bad. changed it and all is OK now. i hope this helps you out. Edited by: cruser92
 
  #4  
Old 06-07-2006, 10:29 AM
Junior Member
Join Date: Apr 2006
Location: United States
Posts: 2
Default



What engine does your trooper have? I don't know about the V6 but I know my 2.6L amigo 4 banger is equipped with an air pump (stupid emissions law says that if your car came equipped with it, you have to leave it there, and it has to work too, or you fail emissions..atleast here in NJ) But anyway, The air pump is LOUD, and it definately ROARS. It's intermittent, turning on and off when it needs to, mine comes on mostly when i first start the engine and it stays on for a few mins, or a few miles. You are probably hearing your air pump, that would be my best guess.
 
  #5  
Old 06-07-2006, 06:07 PM
Super Moderator
Join Date: Nov 2005
Location: United States
Posts: 268
Default

also watch the fan clutch operation,it may not be releasing right.when there fully egaged hot they normally pull alot of air to coool the radiator,if its not disengaging you.ll here the loud roaring on acceleration.esp aftermarket ones
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.