General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

HELP!!!

  #1  
Old 09-12-2007, 04:36 PM
Junior Member
Thread Starter
Join Date: Sep 2007
Location: United States
Posts: 1
Default

Hey all my friend has a 2003 Isuzu Rodeo auto with 40K milesand everytime he turns on the lights, parking or regular, his cruise control stops working. It won't work again until all the lights are turned back off, then it's fine. Also his brake lights are DIM, his third brake light is fine but the others can barely be seen. He said he checked fuses and they are fine, any ideas or help would be greatly appreciated!!![img]smileys/smiley20.gif[/img]
 
  #2  
Old 09-14-2007, 06:38 PM
Member
Join Date: Sep 2007
Location: United States
Posts: 66
Default

Check the grounds, they may all be on the same ground. I dont think it could be fuses. Most acc. are hot wired on to one panel run off the battery. Fallow the pos. line off the the battery and that should lead you to a unit that many wires ar connected to two screws, or on yours it may look like a bar with many lines running off it and into the fire wall. Check these connections, they will corode over time, Pull them of and replace them to make sure proper contact is being made. Let us know what happens next.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
trooper90
Trooper
0
12-01-2006 04:49 PM
hrosenbaum
General Tech
1
02-15-2006 01:04 PM
chuckie
Pickup
4
12-28-2005 09:49 PM
98ZuZu
General Tech
1
04-12-2005 10:01 PM
RODEHO
New Member Area
3
03-07-2005 12:29 PM


Thread Tools
Search this Thread
Quick Reply: HELP!!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.