General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

96 Rodeo - no check engine light - Help!

  #1  
Old 03-20-2012, 03:12 PM
Junior Member
Thread Starter
Join Date: Mar 2012
Posts: 1
Default 96 Rodeo - no check engine light - Help!

Hi everyone, looks like a great forum here and I'm sure I'll be visiting often!

Just bought a 96 Rodeo 6cyl, 2wd and have a couple of nagging problems.

1. Cannot get the check engine light to come ON. Tried to smog it and it passed all the emmissions but faile visual as the CEL won't come on at startup. Computer showed two codes, both for the throttle position indicator. I replace that and also the CEL bulb but still getting nothing - any advice on where to look next?

2. Speedometer is very erratic, sometimes dead at 50mph, sometimes showing 40 - 50 mph when stopped.

Many thanks in advance for any advice

K
 
  #2  
Old 04-13-2012, 09:29 PM
Junior Member
Join Date: Apr 2012
Posts: 25
Default

hi dude this steve martin awaked by the information you have produced in this site
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sammie white
Rodeo
1
09-29-2011 10:50 AM
04RODEO
Rodeo
0
06-11-2008 10:28 AM
collyswamper
IF Help & Suggestion Center
0
03-22-2008 11:27 AM
hrosenbaum
General Tech
1
02-15-2006 01:04 PM
RODEHO
New Member Area
3
03-07-2005 12:29 PM


Thread Tools
Search this Thread
Quick Reply: 96 Rodeo - no check engine light - Help!


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.