General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

4x4 light flashing

  #1  
Old 10-22-2011, 07:35 AM
Junior Member
Thread Starter
Join Date: Oct 2011
Posts: 3
Default 4x4 light flashing

Also have a blinking 4X4 light 99 Amigo. Have checked all the vac lines and everything seems to be fine. Replaced the 4x4 sol on the drivers side firewall and it does not appear to give vac on the 4x4 (gray connector) when button is pushed. When the vac lines are swapped the 4x4 does engage when the button is pushed but still blinks. I do get voltage to both the gray and the blue on the sol. It just appears that the button is not closing the blue and opening the gray sol when pushed. The blue always has constant suction.

I did just find the Diff switch wires on the front axle were rotted and not connected. I ordered a new one but i do not think it is causing the issue from what I have read in other threads. Just for the hell of it i removed the 4x4 control under the center rest and inspected it for shorts and it looks ok.
 
  #2  
Old 10-29-2011, 07:49 PM
Junior Member
Join Date: Oct 2011
Posts: 1
Default

I have a the same truck and mine will not start and the truck will not move even in neutral. It cranks and the 4WD light flashes but no start and cannot get it to move no matter what.

Guys on other forum say I should disconnect motor on side of transfer case and then put it in neutral with pliers just to get in to a garage.

Wish I had known this was really a GM product when I bought it new! A repair every six months with this truck and the frame is as rotted as a thirty year old salt truck!
 
  #3  
Old 11-02-2011, 11:26 AM
Junior Member
Join Date: Feb 2011
Posts: 16
Default

You'll probably have more luck here:
http://forum.planetisuzoo.com/
It's a much more active forum, and not as much spam either.
 
  #4  
Old 11-14-2011, 07:34 PM
Junior Member
Join Date: Nov 2011
Posts: 18
Default

Hey I liked your same truck post & I hope you will get sell this on good time !
 
  #5  
Old 12-13-2011, 01:32 AM
Junior Member
Join Date: Dec 2011
Posts: 3
Default

I should disconnect motor on side of transfer case and then put it in neutral with pliers just to get in to a garage.
 
  #6  
Old 01-05-2012, 12:32 AM
Junior Member
Join Date: Jan 2012
Posts: 10
Default

I have read in other threads. Just for the hell of it i removed the 4x4 control under the center rest and inspected it for shorts and it looks ok.
 
  #7  
Old 01-13-2012, 09:40 PM
Member
Join Date: Sep 2011
Posts: 76
Default

I have a the same truck and mine will not start and the truck will not move even in neutral. It cranks and the 4WD light flashes but no start and cannot get it to move no matter what.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rmac
Trooper
26
10-18-2015 05:30 PM
big tom
General Tech
6
04-06-2011 02:30 AM
mananambal
Rodeo
2
09-22-2007 07:48 PM
rmac
Trooper
0
08-16-2007 09:31 AM


Thread Tools
Search this Thread
Quick Reply: 4x4 light flashing


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.