2001 Vehicross Blowing "Engine Fuse CB-3" - Isuzu Forums - Isuzu Enthusiasts Forum


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 11-15-2011, 10:55 PM
Junior Member
Thread Starter
 
Join Date: Nov 2011
Location: Austin, TX
Posts: 1
Default 2001 Vehicross Blowing "Engine Fuse CB-3"

Hello Yall,
My 2001 Vehicross started blowing the 15amp Engine fuse "CB-3". Has anyone experienced this issue before on their Isuzu and if so what was it and how did you fix it?

Thanks a lot in advance
Reply With Quote
  #2  
Old 11-19-2011, 07:53 AM
Junior Member
 
Join Date: Nov 2011
Posts: 18
Default

seems to be the common standpoint be it Hyundai, Volkswagen or more recently !
Reply With Quote
  #3  
Old 12-28-2017, 06:19 PM
Junior Member
 
Join Date: Dec 2017
Posts: 1
Default

did you ever find out the solution about your fuse blowing. I have a 2000 Vehicross and having the same problem.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
ECM fuse keeps blowing. zaggal5525 Rodeo 1 09-04-2011 12:06 PM
'99 trooper blowing fuse 4 "ignition electrical" jackc396 Trooper 0 10-03-2009 03:53 PM
96 Rodeo main fuse keeps blowing dailyadam Rodeo 0 06-26-2009 06:00 PM
keep blowing fuse for inside dash lights isuz Trooper 0 10-09-2008 10:44 PM
95 Pick-up ECM fuse keep blowing dwright44 Pickup 0 07-25-2005 01:56 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors

All times are GMT -5. The time now is 01:23 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.