Rodeo Talk about Isuzu Rodeo related topics here...

Check Engine light during acceleration

  #1  
Old 01-08-2009, 11:24 PM
Junior Member
Thread Starter
Join Date: Jan 2009
Location: United States
Posts: 2
Default


I was just wondering if any of you have experienced this before. When I turn my 93 v6 auto on, there''s no CEL. I can drive gently and get no light, but when I give it a little more gas, the CEL lights up. Then it goes off once I come to a stop or coast for a little bit. And it just passed Nevada smog like this. I haven''''t had Autozone pull the code yet b/c I don''t even know if it would be stored since the light keeps going out. WTF?
Edited by: KaiserSoze
 
  #2  
Old 01-09-2009, 12:46 PM
Junior Member
Thread Starter
Join Date: Jan 2009
Location: United States
Posts: 2
Default



:::UPDATE:::


This morning after having been parked on a slight incline all night, it wouldn''t start. Then after I moved it to flat ground so I could get my other car out of the garage my wife was able to start it right up. Could this and the CEL be caused by a failing fuel pump (i.e. not being able to provide enough fuel under accel and going lean but providing enough at idle)or was this morning caused by my fuel gauge not being very accurate and not really having a 1/4 tank of gas? Thanks in advance.
 
  #3  
Old 01-09-2009, 07:20 PM
Senior Member
Join Date: Jan 2006
Location: United States
Posts: 525
Default

Go to autozone and have the CEL codes read. Even if the light isnt on the computer will store the codes. Without knowing what codes are coming up its all just guessing.

If you tend to let your gas tank get below 1/4 tank then it could be a failing fuel pump. These fuel pumps need to be surrounded by fuel to keep them from over heating. Letting it get below 1/4 often will cause it to burn out.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Homuqtesa
Rodeo
0
02-16-2009 02:27 PM
collyswamper
IF Help & Suggestion Center
0
03-22-2008 11:27 AM
d1n0
Rodeo
1
06-12-2006 03:21 PM
devildawg00311
Rodeo
2
05-16-2006 03:58 PM
Spud
Trooper
2
03-03-2006 08:32 PM


Thread Tools
Search this Thread
Quick Reply: Check Engine light during acceleration


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.