Go Back  Isuzu Forums - Isuzu Enthusiasts Forum > General > New Member Area
Reload this Page >

1999 isuzu rodeo 3.2l blowing 10a starter fuse

New Member Area New to IF? Stop in tell us about you...

1999 isuzu rodeo 3.2l blowing 10a starter fuse

  #1  
Old 10-24-2018, 07:22 AM
Junior Member
Thread Starter
Join Date: Oct 2018
Posts: 1
Default 1999 isuzu rodeo 3.2l blowing 10a starter fuse

I have a 1999 Rodeo that is blowing the starter fuse. I disconnected the starter and the fuse did not blow. I replaced the starter and it worked great for a week then blew the fuse again. Disconnected the starter and it still blows the fuse. Does anyone have any suggestions. Your help would be greatly appreciated.
 
  #2  
Old 10-31-2018, 06:57 PM
Junior Member
Join Date: Oct 2018
Posts: 2
Default

did you try replacing the starter relay? would either be the relay, where the relay connects to fuse box or the wire harness.
 
  #3  
Old 11-24-2018, 03:22 AM
Junior Member
Join Date: Oct 2018
Posts: 26
Default

IDK ur problem. Welcome to forum.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Gateway1
General Tech
3
09-24-2017 11:23 PM
Mr. Bear
Rodeo
0
10-24-2015 06:24 PM
dailyadam
Rodeo
0
06-26-2009 05:00 PM
dwright44
Pickup
0
07-25-2005 12:56 AM


Thread Tools
Search this Thread
Quick Reply: 1999 isuzu rodeo 3.2l blowing 10a starter fuse


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.