General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

Squeaky truck! :(

  #1  
Old 02-12-2007, 01:26 PM
Junior Member
Thread Starter
Join Date: Feb 2007
Location:
Posts: 2
Default



Hi, I drive a squeaky '98 Isuzu Hombre.
The squeaks will occur about 5 minutes after being on the road. It comes from underneath the car - can't tell exactly where but definitly front end. The squeaks go along with the wheel as it turns. So ever 1 turn of the wheel I get 1 squeak. When at full speed it's obviously one big long squeak. When I apply my breaks - the squeak goes away (I think this may rule out bad break pads). The squeak is independant of the transmission as when I'm in neutral and coasting down the highway it will still squeak as much as if I was in gear. Again though - everytime I apply my breaks it goes away. On days that it rains the squeaks take longer to show up then dry days. My conclusion is something needs to be lubed but I don't know what =/


Any help would be GREATLY appreciated.


Thank you in advance!
 
  #2  
Old 02-14-2007, 10:59 PM
Junior Member
Join Date: Jan 2007
Location: United States
Posts: 1
Default



It could be your hood...i have a 2000 isuzu rodeo and had a similar thing going on...it was my hood...all it was , was the two rubber screw things that hold pressure on the hood needed to be adjusted cuz they werent on the hood and the hood was bouncin up and down while going down the road...possible that could be your solution too...


idk for sure
 
  #3  
Old 05-16-2007, 05:18 PM
Junior Member
Join Date: May 2007
Location: United States
Posts: 5
Default



Squeaky,


I guess you got to your problem, but applying the brakes won't rule them out as the casuse of your squeaking/squealing.











Originally Posted by SqueakyHombre


Hi, I drive a squeaky '98 Isuzu Hombre.
The squeaks will occur about 5 minutes after being on the road. It comes from underneath the car - can't tell exactly where but definitly front end. The squeaks go along with the wheel as it turns. So ever 1 turn of the wheel I get 1 squeak. When at full speed it's obviously one big long squeak. When I apply my breaks - the squeak goes away (I think this may rule out bad break pads). The squeak is independant of the transmission as when I'm in neutral and coasting down the highway it will still squeak as much as if I was in gear. Again though - everytime I apply my breaks it goes away. On days that it rains the squeaks take longer to show up then dry days. My conclusion is something needs to be lubed but I don't know what =/


Any help would be GREATLY appreciated.


Thank you in advance!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
808State
Pickup
3
11-15-2012 01:25 AM
lorenwalding
General Tech
0
05-16-2008 02:04 PM
SqueakyHombre
Hombre
2
08-01-2007 08:34 AM
2low2go
Pickup
2
11-29-2006 10:35 PM
lukeshow
Rodeo
4
08-17-2006 02:31 PM


Thread Tools
Search this Thread
Quick Reply: Squeaky truck! :(


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.