2004 Rodeo lack of power going up hill - Isuzu Forums - Isuzu Enthusiasts Forum

Thread Tools Search this Thread
Old 08-07-2017, 04:53 PM
Junior Member
Thread Starter
Join Date: Aug 2017
Posts: 1
Default 2004 Rodeo lack of power going up hill

Hello All

2004 Rodeo V6 125K miles runs extremely well.. at least most of the time

On my back from fishing pulling a 1200# boat the engine had no power going up hill - transmission had a complete rebuild 20K ago and was not slipping rpms would just not advance as I pushed gas pedal- once on the flats it got up to freeway speed with no apparent issues but as soon as I started up a grade the lack of power was evident. Today traveling w/o the boat it seems to be running fine. I have had a n check engine lite on for a few months, gas milage seems to be down, exhaust seems to be rich. Hooke up a friends auto link and get error codes


Any advice is much appreciated.

Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
2004 isuzu axiom losing power while driving fendlay Axiom 0 08-13-2013 01:08 AM
Lack of Power 1990Trooper Trooper 1 02-21-2012 02:24 AM
lack of power, 95 trooper, manual tranny demet123 Trooper 0 05-07-2011 02:05 PM
3.1 fuel mileage...or lack of BlueRodeo Rodeo 2 09-24-2006 11:08 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Featured Sponsors

All times are GMT -5. The time now is 12:09 AM.

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.