General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

1990 Trooper idle problem

  #1  
Old 05-05-2006, 12:38 AM
Junior Member
Thread Starter
Join Date: May 2006
Location: United States
Posts: 7
Default

My o2 light came on a while back and I continued to drive the trooper because there was no difference in performance. Today after driving around half of the day, I went to start it and got a poof sound from under the hood followed by some blue smoke. It starts but will not idle. I drove it to the parts store, thinking that the o2 sensor finally died and replaced it. The light is still on and the thing still fails to idle. What could be the problem and or solution? Thanks in advance, Joe
 
  #2  
Old 05-05-2006, 12:45 AM
Super Moderator
Join Date: Nov 2005
Location: United States
Posts: 268
Default

i,m guessin its an older yr? early 90s late 80s.? give me more info
 
  #3  
Old 05-05-2006, 12:46 AM
Junior Member
Thread Starter
Join Date: May 2006
Location: United States
Posts: 7
Default

Im sorry, It is a 1990 model Trooper. Thanks
 
  #4  
Old 05-05-2006, 12:52 AM
Super Moderator
Join Date: Nov 2005
Location: United States
Posts: 268
Default

the o2 light is just a maitance light it can be reset but you havae to remove the gauge cluster to do so.how does it run above idle an around town?
 
  #5  
Old 05-05-2006, 12:55 AM
Junior Member
Thread Starter
Join Date: May 2006
Location: United States
Posts: 7
Default



It seems to run rougher than normal but the more rpms or higher speeds itseems to run fairly good.
 
  #6  
Old 05-05-2006, 12:55 AM
Super Moderator
Join Date: Nov 2005
Location: United States
Posts: 268
Default

you must have just triped 80k or 90k miles.that pretty low miles for that yr.
 
  #7  
Old 05-05-2006, 12:59 AM
Super Moderator
Join Date: Nov 2005
Location: United States
Posts: 268
Default

2.6l engines dont have many driveablity problems ,but they burn valves easy.do you havae a good mechanic if so get your valves checked for being to tight when they get high in mileage they tighten instead of looseing.also it can be just a simple idle adj fix,an tune up.is it carberated if so its a 2.3 liter?
 
  #8  
Old 05-05-2006, 01:01 AM
Junior Member
Thread Starter
Join Date: May 2006
Location: United States
Posts: 7
Default

It is a 2.6 with 186,000 + miles but has been driving fine until the poof.
 
  #9  
Old 05-05-2006, 01:02 AM
Junior Member
Thread Starter
Join Date: May 2006
Location: United States
Posts: 7
Default

could it be IAC problem or something like that?
 
  #10  
Old 05-05-2006, 01:07 AM
Super Moderator
Join Date: Nov 2005
Location: United States
Posts: 268
Default

oh 86k good then the o2 has been reset before,this will make your job easier.they dont have iac.but check th eplastis pipe betwwen the t-body an air cleaner,makae sure it doesnt have a burn hole right below where the exhaust manifold is an the air injection pipe runs along.also check for any vacuum leaks,mass airflow sensor try uplugging it an see if it idles then.the 2.6 are good engines the problem shouldnt be mayjor.when the last time you had a tune up? i mean the plastic pipeEdited by: ISUZUGURU
 

Thread Tools
Search this Thread
Quick Reply: 1990 Trooper idle problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.