Go Back  Isuzu Forums - Isuzu Enthusiasts Forum > Brand Review > Engine and Internal
Reload this Page >

Help! Isuzu LT134P no power to go uphill after changing gasket

Engine and Internal Chat about beefing up your insides here...

Help! Isuzu LT134P no power to go uphill after changing gasket

  #1  
Old 01-15-2019, 07:26 AM
Junior Member
Thread Starter
Join Date: Jan 2019
Posts: 3
Default Help! Isuzu LT134P no power to go uphill after changing gasket



Hi, I am a new member here. I have a bus model LT134P with engine model 6HK1TC. Recently, I have overheated the engine. But after repairing by changing the gasket, my vehicle have no power to go uphill. And I noticed my RPM meter is not working perfectly( going opposite direction).

The mechanics have already tried their best but they still could not find a solution.

Things i I have spent lots of money on repairs:
1) Fuel pump
2) turbocharger
3) checking of piston, con rod, and piston rings

i am very desperate to find a solution and hopefully any experts here can help me out with my situation.
Would greatly appreciate it.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Danny Ooi
IF Help & Suggestion Center
0
01-15-2019 07:24 AM
mananambal
Rodeo
1
11-18-2011 09:55 AM
mreed1587
Trooper
1
05-26-2011 03:48 AM
Precisionods
Trooper
0
02-28-2010 02:51 PM


Thread Tools
Search this Thread
Quick Reply: Help! Isuzu LT134P no power to go uphill after changing gasket


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.