General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

Clutch question

  #1  
Old 08-08-2007, 03:21 PM
Junior Member
Thread Starter
Join Date: Nov 2005
Location: United States
Posts: 11
Default



Hi all,


I recently changed the clutch on my 92 Trooper S MT and now the car rattles a little when in the first gear. Any ideas why this is happening? Thanks.
 
  #2  
Old 08-11-2007, 04:12 AM
Junior Member
Join Date: Aug 2007
Location:
Posts: 24
Default








1. Broken, loose or weak anti-rattle springs,
tension springs pull-back springs, collar springs</span>

2. Excessive clearance between pressure plate lugs
and cover</span>



3. Loose or worn flywheel dowel or driving pins</span>



4. Worn drive lugs, pins or posts on pressure
plate</span>



5. Broken or loose clutch plate hub</span>



6. Worn clutch plate splines</span>



7. Worn main drive gear splines</span>



8. Excessive backlash in transmission</span>



9. Loose or worn universal joints</span>



10. Dry or worn pilot bearing</span>



11. Dry or worn throwout bearing</span>

12. Damaged isuzu radiator
</span></span>
Edited by: kurtdaniel
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
maddhatter
Trooper
1
01-06-2009 01:43 AM
markjw
Rodeo
1
10-09-2008 12:34 AM
spearbang
Rodeo
3
08-11-2008 04:59 PM
alanrush2004
Rodeo
5
05-28-2008 01:09 AM
Harleygirl
Rodeo
3
06-15-2005 05:31 PM


Thread Tools
Search this Thread
Quick Reply: Clutch question


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.