General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

2000 Amigo trans light / cruise control

  #1  
Old 08-31-2006, 04:26 PM
Junior Member
Thread Starter
Join Date: Aug 2006
Location: United States
Posts: 1
Default


< =>
<!--
var SymRealOnLoad;
var SymReal;

Sym()
{
window.open = SymWinOpen;
if(SymReal != null)
SymReal();
}

SymOnLoad()
{
if(SymRealOnLoad != null)
SymRealOnLoad();
window.open = SymRealWinOpen;
SymReal = window.;
window. = Sym;
}

SymRealOnLoad = window.onload;
window.onload = SymOnLoad;

//-->
</>
[img]smileys/smiley7.gif[/img]I just bought a 2000 Amigo 2wd v6 from a Saturn dealer. Inspection guarunteed and 90 day 3,000 mile limited powertrain warranty. Had it for two weeks and it ran great... like new. Took it in for them to replace the wiper motor and while it was there, had them replace the plugs, plug bots, serpentine belt, and fuel filter. Picked it up and the trans light came on, cruise control light was turning itself on and off, and the tranny was shifting very hard and jerking. Took it around the block and right back to the dealer. They sent it to Isuzu who had it for a month. They replaced a large wire harness and the main computer. Saturn picked it up and it still had a problem so Isuzu re-programmed the computer. Saturn got it backl and replace the cruise control / wiper switch and the intermittant wipers still don't work. They ordered a wiper relay and I took the car home. I've been driving it for about three days now and while going around a pretty sharp curve at about 45, the tranny light and cruise control came on again and the tranny violently downshifted and sputtered. It happened for about 30 seconds and went back to normal. Anyone now whats happening because the dealerships don't have a clue and I really like this truck. It's a third vehicle, so I don't mind them taking their time and fixing it right. My friend said that his jeep had this problem and had a bad automatic tran. module that had to be replaced, does the Amigo have one ???? I'd appreciate any help. This is my first Isuzu and don't know much about them. Thanks in advance. Rick
 
  #2  
Old 09-03-2006, 12:00 PM
Super Moderator
Join Date: Nov 2005
Location: United States
Posts: 268
Default

wow that is weird.sounds like you have a lose connection somewhere.i,m surprised the dealership didnt find exactly what the problem was.when replacing the engine wiring harness they should have definatly noticed something,ive replaced a few myself.i would recheck theground connections on the engine first.there should be 3 on top of the intake.1 big one above the alternator bolted to the bracket.another one below the alternator connected to the frame rail.1 beside the battery towards the firewall side,an 1 on each fender well left an right.make sure they all are CLEAN AN TIGHT.grab them make sure they DO NOT MOVE.these are the most common ones that are either left loose or damaged.an see if you can get a carfacts report on it.an look closely for any bodyshop work.if the vehicle has been wrecked an can bring on weird problems like that.are there any check engine lights?the trans light comming on is just like the check engine,it will store codes to be diagnosed. an check the blue ,green,black connector below the airbox,between the aircleaner an headlights,makae sure they are connected tightly.open them up an reconnect them.when you say these problems occur on making sharp turns,it make me think that something is loose an moving apart,keep that in mind.Edited by: ISUZUGURU
 
  #3  
Old 09-04-2006, 01:14 AM
Junior Member
Join Date: Jul 2006
Location: United States
Posts: 9
Default

check the spark plugs, use Denso platnum plugs. still had major twitches like this even with good grounds to the crank sensor. Bosch plus seem to cause very strange "hiccups" like this. it's a quick, easy check you can do
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sammie white
Rodeo
1
09-29-2011 10:50 AM
undershadetree
General Tech
0
03-08-2009 05:20 PM
TexasRodeo
Rodeo
1
10-25-2008 08:36 PM
ibguyb
Rodeo
3
08-20-2007 10:00 PM
brad
Rodeo
0
01-22-2006 02:54 AM


Thread Tools
Search this Thread
Quick Reply: 2000 Amigo trans light / cruise control


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.