Amigo Talk about Isuzu Amigo related topics here...

93 Amigo was Running then died

  #1  
Old 08-29-2016, 02:59 PM
Junior Member
Thread Starter
Join Date: Aug 2016
Posts: 1
Question 93 Amigo was Running then died

I just bought a 93 Isuzu Amigo last month I was driving home from work a couple of days ago and I barely got 500ft before it died. I got it towed home and was able to get it to start on starter fluid but I cannot get to stay running or start on it's own. Any help would be greatly appreciated.
 
  #2  
Old 08-30-2016, 10:28 AM
Junior Member
Join Date: Jan 2016
Posts: 4
Default

most likely bad fuel pump and /or filter
 
  #3  
Old 09-05-2018, 01:50 AM
Junior Member
Join Date: Aug 2018
Location: California
Posts: 16
Default

It mostly seems the fuel pump problem or the exhaust coil through which air flow or lubricants intended..You can also check out the air filter ,it may helped..!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
chuckwagon1971
Rodeo
0
06-26-2016 10:35 AM
ScreaminAmigo
Amigo
5
11-11-2008 05:35 PM
mn840sc
Trooper
7
09-12-2008 04:56 PM
RodeoRaymon
Rodeo
12
12-28-2007 07:38 PM


Thread Tools
Search this Thread
Quick Reply: 93 Amigo was Running then died


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.