Go Back   Isuzu Forums - Isuzu Enthusiasts Forum > Past Models > Rodeo
Sign in using an external account
Register Forgot Password?
Connect with Facebook
Search


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-02-2006, 04:16 PM
shylexx shylexx is offline
Junior Member
 
Join Date: Dec 2006
Location: United States
Posts: 4
Default

About a week ago my check engine light turned on. Now my 98 rodeo 4WD V6 has an erratic idle (rpm needle jumps from below 1 to almost 3) when ever I turn it on and if I don't leave the engine rev'ed above 1000 rpm it stalls. I took the car to Autozone to have the codes read and they told me that coil number 3 is misfiring and both O2 sensors are bad. I can't remember the actual codes. I was told to change the spark plugs just incase but nothing changed. Should I change everything or is their something else that can give these readings.
Reply With Quote
  #2  
Old 12-03-2006, 04:23 AM
Gizmo42 Gizmo42 is offline
Senior Member
 
Join Date: Jan 2006
Location: United States
Posts: 525
Default

A bad Intake Manifold Gasket will cause it and is most likely the problem. Its a common problem on '98 and '99. Isuzu has lowered the torque spec on the intake a few times to prevent it from happening as well as redesigned the gaskets (originals are some kind of thick plastic).

Also a dirty/clogged Idle Air Control valve can cause the eratic idle but not sure if that would throw the same engine light codes as a manifold gasket.

__________________
--Dave
1999 Rodeo LS 3.2 4x4 5 Speed
32x11.50-15 BFG T/A KO
3\" Lift - Rancho 9000x
Rear no-slip locker

There is a very fine line between \"hobby\" and \"mental illness.\" Dave
Reply With Quote
  #3  
Old 12-04-2006, 11:58 PM
MASTERTECH MASTERTECH is offline
Member
 
Join Date: Nov 2005
Location: United States
Posts: 92
Default

if the vehicle has a misfire for #3 cylinder you need to fix this first then worry about the o2 sensor codes, they could be set due to a misfire, if you swap the coil #3 (in the middle passenger side) with #1 coil see if it moves with the cylinder if it does then replaced that coil in not then look at an injector spray pattern
Reply With Quote
  #4  
Old 12-09-2006, 08:13 PM
shylexx shylexx is offline
Junior Member
 
Join Date: Dec 2006
Location: United States
Posts: 4
Default

Well It seems the problem was the intake manifold gaskets. I just finished replacing them and when I turned on the truck It ran better than ever. The Idle was perfect, the check engine light did not come on, and the truck ran perfect. Just want to say thanks for all of your help.
Reply With Quote
  #5  
Old 01-04-2007, 12:28 PM
carlover626 carlover626 is offline
Junior Member
 
Join Date: Jan 2007
Location: United States
Posts: 2
Default

How difficult was the Intake Gasket to replace?
Reply With Quote
  #6  
Old 01-04-2007, 07:30 PM
shylexx shylexx is offline
Junior Member
 
Join Date: Dec 2006
Location: United States
Posts: 4
Default

It was fairly simple, about a day and a half but that was because It was really cold and windy those days so I kept going inside for breaks . I also have the repair manual so that was helpful but if you dont have one you might want to check this out http://isuzufaq.ibctech.ca/#faq5
Reply With Quote
  #7  
Old 01-05-2007, 01:50 AM
oilsand sparky oilsand sparky is offline
Junior Member
 
Join Date: Oct 2006
Location: Canada
Posts: 8
Default

i had that same problem 2001 rodeo ls 4wd , intake gasket manifold. same diagnostics from the computer. I learnt the hard way, by replacing both o2 sensors before bring it in to the dealership
__________________
GIL
2001 Rodeo LS 4x4
automatic
95000kms
Reply With Quote
  #8  
Old 11-23-2008, 10:04 PM
parra parra is offline
Junior Member
 
Join Date: Mar 2008
Location: Mexico
Posts: 11
Default



Hi every body, could You let Me know if the intake manifoldgasket, give You an intermitent up idle to 1400rpm.


I have been with this problem for about an a Year. already bought twice the iac valve and one EGR valve and the problem still intermitent, I running My Rodeo 98 at the beginning run ok and suddenly the RPM goes to 1200 or 1400rpm, I need to get the engine goes to warm or cool and the rpm get normal again.


NEED HELP..


THANKS IN ADVANCE ....
Reply With Quote
  #9  
Old 07-07-2009, 10:49 AM
sajid753 sajid753 is offline
Junior Member
 
Join Date: Mar 2009
Posts: 2
Default

Hey guys, im experiencing similar issues. The idle had gotten so bad that the car wasnt turning over anymore. So i ended up pulling the upper manifold off and replacing all 6 injectors, fuel filter, and gaskets. The car still wasnt starting so i swapped the Throttle Position Sensor and it fired right up and was idling normally. However the check engine light was still coming off and the error code read that the car was running lean. About a month later, the car starting idling high again so i replaced the TPS again and it ran fine for a few more weeks and now its doing the same thing again. I dont want to replace the TPS again becuase i think there is something else thats at the root of the problem. If i unplug the TPS though, the car drops down to normal RPMs so im really confused. Also, ever since i pulled the upper manifold off and replaced everything the car takes a few extra cranks to actualy turn over and start. Not sure if thats related or not...but what else can I try to diagnose this issue??
Reply With Quote
  #10  
Old 07-07-2009, 09:45 PM
mdshann mdshann is offline
Junior Member
 
Join Date: Jul 2009
Posts: 4
Default

My upper gasket went bad about 2 years ago. The lower went bad about 6 months later. Try replacing the lower gasket. A trick that a friend of mine told me to do was start the car and get a can of carb cleaner and spray the gasket where the manifold halves meet and where the lower manifold meets the engine and if the idle changes you have a leak. As soon as I started spraying the idle became almost normal and when the liquid evaporated the temporary vacuum seal left and the car had idle problems again. Be for-warned the second time I had idle problems I took it to a mechanic and he told me there was a hairline crack in the manifold and it needed replaced with a grand total of $2200! I took it to someone I knew and had him do the upper and lower gaskets and the problem was fixed for $500! So if a mechanic wants to replace the manifold tell him to do the gaskets and only the gaskets first!
Reply With Quote
Old 07-07-2009, 09:45 PM
 
 
 
Reply

Tags
1999, 98, bad, gasket, high, idle, idling, intake, irattic, isuzu, manifold, problem, replace, rodeo, rpm


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Advertising

Featured Sponsors
Our Sponsors
All times are GMT -5. The time now is 08:37 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.