View Full Version : Rear brakes lock up (?)


Rbell19
01-23-2007, 07:29 PM
< =>
<!--
var SymRealOnLoad;
var SymReal;

Sym()
{
window.open = SymWinOpen;
if(SymReal != null)
SymReal();
}

SymOnLoad()
{
if(SymRealOnLoad != null)
SymRealOnLoad();
window.open = SymRealWinOpen;
SymReal = window.;
window. = Sym;
}

SymRealOnLoad = window.onload;
window.onload = SymOnLoad;

//-->
</>
I thought I had a transmission problem - but now it seems like my rear wheels lock up. When I drive my 1999 Rodeo for 30 minutes or more in the city, it seems to lose power and 'drag'. Went to a transmission shop who said it was fine. Today when it happened, I jacked up the rear end and the wheels would not move. Seems like the emergency brake was locked on - I did not have or put it on. But the rear brakes were locked. After setting for 30 minutes or more, the brakes cool off and release. Only to start the problem all over again. Where do I go from here? ABS, e-brake, calipers? Any advice please?

MASTERTECH
01-25-2007, 12:07 AM
check for the wrong fluid in the brake master cylinder, and if it is the whole brake system will need to be rebuilt, when you lift the cap on the master cylinder if the rubber seal inside is twice its size and will not fit it is contaminated and you will need a rebuild.


All of the rubber components will need to be replaced, I would rebuild the calipers and replaced the hoses and master cyliner and wheel cylinders (2WD) and preportioning valve and abs hyd unit

Rbell19
01-30-2007, 08:00 PM
< =>
<!--
var SymRealOnLoad;
var SymReal;

Sym()
{
window.open = SymWinOpen;
if(SymReal != null)
SymReal();
}

SymOnLoad()
{
if(SymRealOnLoad != null)
SymRealOnLoad();
window.open = SymRealWinOpen;
SymReal = window.;
window. = Sym;
}

SymRealOnLoad = window.onload;
window.onload = SymOnLoad;

//-->
</>
Thanks - the fluid was checked and is fine. Thinking the ABS system maybe.


rbell19

jetmech09
02-04-2007, 11:39 AM
sounds like you may have moisture in the brake fluid. once the fluid gets hot your brakes lock up. I had the same problem on my other car. Changed fluid and problem whent away. Good Luck.

MASTERTECH
02-05-2007, 10:06 PM
check the adj on the parking brake, you may have it to tight, and when they get hot and expand they lock up