View Full Version : Torque On Demand Issue


sicilian68
09-06-2007, 10:09 PM
I have a 2001 Trooper with just under 85K miles. Recently the TOD dash panel lights have started flashing on the rear tires with the orange "check" flashing simultaneously, but ONLY when in 2WD. When in AWD or 4L there are no flashing lights nor "check" light flashing. Vehicle still operates properly in 2WD, AWD, and 4L. Anybody possibly have an idea of what needs checked or what is going on with the flashing dash panel lights???? Also, if ignored can any mechanical damage happen to the drive system?Edited by: sicilian68

Isuzutech
09-15-2007, 06:05 PM
TOD codes are usually caused by dirty or failing speed sensors....One input and one output on the TOD to the tune of about 375.00 each plus installation. usually won't cause any damage but will probably render the TOD inoperable once they do go completely.Wont leave you stranded just no TOD

sicilian68
09-17-2007, 08:14 AM
Thank you very much for that info. Having stated that about the speed sensors, can you tell me where the one(s) you reference to would be located so I can try cleaning them or replacing if need be? In the research I have done, there appears to be five different sensors: two on the front differential, two on top of the transmission/transfer case, and one at the tail-end of the transmission. Which one(s) are you referring to? And it is a relief to know that if it goes out completely it won't leave me on the roadside. Thanks.


Edited by: sicilian68